Jump to content

Download: (SOS31) Forums Moderators in Board Index


Adriano Faria
 Share

Recommended Posts

File Name: (SOS31) Forums Moderators in Board Index
File Submitter: Adriano Faria
File Submitted: 03 Jun 2010
File Updated: 21 Feb 2011
File Category: Hooks and Plugins

%7Boption%7D

This hook will show forums moderators in board index and subforums.

Notes:

  • Compatibility: IP.Board 3.1.X
  • EDITS: No file or template edit required


Click here to download this file
Link to comment
Share on other sites

There was an error in instructions file. The file was reuploaded. The right (second) edit in admin/applications/forums/sources/classes/forums/class_forums.php is:

Find:

					if ($moderator['isg'] == 1)

					{

						$mod_string[] = array( "{$this->settings['base_url']}app=members&section=view&module=list&max_results=30&filter={$moderator['gid']}&sort_order=asc&sort_key=members_display_name&st=0&b=1", $moderator['gname'], 0 );

					}

					else

					{

						if ( ! $moderator['name'] )

						{

							continue;

						}

						$mod_string[] = array( $this->registry->getClass("output")->buildSEOUrl( "showuser={$moderator['memid']}", "public", $moderator['seoname'], 'showuser' ), $moderator['name'], $moderator['memid'] );

					}

Replace with:

                                    	if ($moderator['isg'] == 1)

                                    	{

                                            	if ( !$this->settings['sos30_moderatorsindex_format'] )

                                            	{

                                                    	$mod_string[] = array( "{$this->settings['base_url']}app=members&section=view&module=list&max_results=30&filter={$moderator['gid']}&sort_order=asc&sort_key=members_display_name&st=0&b=1", $moderator['gname'], 0 );

                                            	}

                                            	else

                                            	{

                                                    	$mod_string[] = array( "{$this->settings['base_url']}app=members&section=view&module=list&max_results=30&filter={$moderator['gid']}&sort_order=asc&sort_key=members_display_name&st=0&b=1", $this->caches['group_cache'][ $moderator['gid'] ]['prefix'].$moderator['gname'].$this->caches['group_cache'][ $moderator['gid'] ]['suffix'], 0 );

                                            	}


                                    	}

                                    	else

                                    	{

                                            	if ( ! $moderator['name'] )

                                            	{

                                                    	continue;

                                            	}


                                            	if ( !$this->settings['sos30_moderatorsindex_format'] )

                                            	{

                                                    	$mod_string[] = array( $this->registry->getClass("output")->buildSEOUrl( "showuser={$moderator['memid']}", "public", $moderator['seoname'], 'showuser' ), $moderator['name'], $moderator['memid'] );

                                            	}

                                            	else

                                            	{

                                                    	$mod_string[] = array( "{$this->settings['base_url']}showuser={$moderator['memid']}", $this->caches['group_cache'][ $moderator['mgroup'] ]['prefix'].$moderator['name'].$this->caches['group_cache'][ $moderator['mgroup'] ]['suffix'], $moderator['memid'] );

                                            	}


                                    	}

Link to comment
Share on other sites

i get into admin forum modules.. but cant find where it says in the read me to go

admin/applications/forums/modules_admin/forums/moderator.php

when i get to admin modules, then click forums it says edit module but there is nothing about moderators.

sorry I am brand new to this.

Link to comment
Share on other sites


Did you do the file edits specified in readme.html?





Where do I make the changes? Do I do it in Admin CP (I can't seem to find it in there) or do I make the changes on the FTP server?

I am not understanding where admin/applications/forums/modules_admin/forums/moderator.php is.

Thanks for any help you can offer.
Link to comment
Share on other sites

  • 2 weeks later...

OK I have got it on and it is working for the main page. All the forums now have the mods names listed, but they are not showing for the subforums. Does anyone know what I have to do or where I have to edit the code to get it to do this?

TIA

Link to comment
Share on other sites

  • 2 weeks later...

When I tried installing the mod, not only did it remove the "add reply" and "start new topic' buttons but that it also removed the "green tabbed background" that is seen across the top of my forum skin. It also affected some of the graphics on my skins starting with the banner logo and some minor graphics. I had to remove the mod because of these disruptions.

The mod is disappointing as I was hoping that it would work.

Link to comment
Share on other sites

Adriano, actually, it was your mod that caused the problem because I recached my skins after installing your mod. When I restored the original settings and removed your mod, the problem corrected itself. I've actually used some of your mods but this was the first time I installed one of your mods and it scrambled the images and settings for my forum skins.

I'll try your suggestion from your recent post and I hope that it works.

Link to comment
Share on other sites

Hello,

thanks for this useful mod. But its not working for me. I followed the exact instructions, but the Moderators are not listed in board index. Tried that with my custom skin and also with the IP.Board skin.
Any hints ?

Thanks in advance
Best regards
Rolf

Link to comment
Share on other sites

Adriano, there is a problem with the Mod. When I go to remove a Moderator from a particular forum, I get the following error:

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /****/****/public_html/board/admin/applications/forums/modules_admin/forums/moderator.php on line 475

When removing a Moderator, deleting a forum or deleting a category, I get a similar error associated with the Moderator.php file, in particular, with the lines that this mod add to that file.

Link to comment
Share on other sites

Adriano, it's odd. When I was conducting the file edits, the error kept popping up. I had conducted the file edits, exactly as your instruction file indicated. However, upon re-uploading the original source file for moderators.php and applied the same edit, the error no longer appears.

Don't ask me, I cannot explain this and I had tried that same file edit more than a few times and ended up with the error but trying it this most recent time (upon re-uploading the original source file) doesn't display the error.

Link to comment
Share on other sites


OK I have got it on and it is working for the main page. All the forums now have the mods names listed, but they are not showing for the subforums. Does anyone know what I have to do or where I have to edit the code to get it to do this?



TIA





Does anyone know the answer to this? I would like to have the moderators names listed on the subforums also... Is there a way to do this?

TIA
Link to comment
Share on other sites

After I upgraded the 3.1.2 the moderators show for the forums but the group colors won't show on the index. I recached moderators and also the skins themselves but they still won't show. I ran the template merge tool which I suspected could be the issue but when I allowed the custom skin to win my forum got all jumbled so i had to revert back although even jumbled I didn't see the group colors show. Any suggestions?

Link to comment
Share on other sites

  • 3 months later...
Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...