Jump to content

Community

Recommended Posts

Hi!
I have 100k member. And when I swich on member map I can't edit members in AdminCP. I have timeout 502 errror.

I use nginx and PHP-FPM wite request_timeout 30s (both for PHP7 and NGINX). My IPB version is 4.1.x (last)

On screen shot you can see PHP Slow Log.

This error I get only when plugin "Member Map" is on.

 

 

Member_Map.png

Share this post


Link to post
Share on other sites
24 minutes ago, tolik777 said:

Hi!
I have 100k member. And when I swich on member map I can't edit members in AdminCP. I have timeout 502 errror.

I use nginx and PHP-FPM wite request_timeout 30s (both for PHP7 and NGINX). My IPB version is 4.1.x (last)

On screen shot you can see PHP Slow Log.

This error I get only when plugin "Member Map" is on.

That is a known error caused by the "profile synchronization".

Share this post


Link to post
Share on other sites

Some time ago the dev was good enough to produce a mod of this plugin that displayed the members signature in the pop-up on the map. I've just upgraded to 4.x, is there a way to do the same thing now ?

Share this post


Link to post
Share on other sites
20 hours ago, Joel R said:

Thanks for the update and continued maintenance.

2nd that!

Thanks for your effort.

I'd just like to bump my feature request: Could you look into a search feature to search users/markers on the map? This would be highly appreciated by my community and I think others would also benefit from it... would be cool, if it's not a big deal :]

Share this post


Link to post
Share on other sites
18 hours ago, abetts said:

The map page won't load on my site, any ideas what's wrong please? On 3.1.4...

https://www.thelotusforums.com/forums/membermap/

It is loading, it's just leaking memory like crazy. Consuming 1.2GB and all my CPU. Did this happen after the update? Can you enable marker clustering to see if that helps a bit? Did you have all those ad services when the map was working?

Personally I think it's a combination of the huge amount of markers, no clustering, and ad services wanting to process the info from all those markers.

Share this post


Link to post
Share on other sites

Clustering has done the trick, thanks! 

The ads were always there, logged in members see a lot less. 

I don't know why but it's showing 2,100 odd members in Hong Kong and we don't have that many plus a cluster of a similar size all in 1 location in Surrey! 

Edited by abetts

Share this post


Link to post
Share on other sites
17 minutes ago, abetts said:

Clustering has done the trick, thanks! 

The ads were always there, logged in members see a lot less. 

I don't know why but it's showing 2,100 odd members in Hong Kong and we don't have that many plus a cluster of a similar size all in 1 location in Surrey! 

It's these two members that have all the markers in HK and Surrey: https://www.thelotusforums.com/forums/profile/15743-nordschleife666/ & https://www.thelotusforums.com/forums/profile/22262-steve4012/

I'm not on my dev computer right now, but I'll get a DB query you can run to get rid of those markers later tonight.

Share this post


Link to post
Share on other sites
9 hours ago, abetts said:

Brilliant, thank you ^_^

Here you go:

DELETE FROM `membermap_markers` WHERE marker_member_id IN( 21486, 22262, 15743 )

After that you'll need to rebuild the cache, which you can do through the "Admin Tools" menu on the map.

I have no idea how this happened, and if you see this happening again, please let me know.

Share this post


Link to post
Share on other sites

Martin, 

On the Main Map page where the link for "Browse Locations" is located, my members are having a difficult time seeing this. Is there a CSS way to change this from .ipsButton_link to .ipsButton_important specific to only this page? Or if not by CSS, another way to do it?

Thanks

Share this post


Link to post
Share on other sites

Language string in the activity stream:

Showing status updates, news, profiles, updates, topics, files, Members_pl_lc and markers I have not read.

Activity Stream.JPG

Edited by Joel R

Share this post


Link to post
Share on other sites
11 hours ago, Peter Drinkwater said:

Martin, 

On the Main Map page where the link for "Browse Locations" is located, my members are having a difficult time seeing this. Is there a CSS way to change this from .ipsButton_link to .ipsButton_important specific to only this page? Or if not by CSS, another way to do it?

Thanks

Edit the template 'showMap' in membermap > front > map. Replace 'ipsButton_link' with any of the following: 

 

11 hours ago, Joel R said:

Language string in the activity stream:

Showing status updates, news, profiles, updates, topics, files, Members_pl_lc and markers I have not read.

If it's "member_pl_lc" you're on about, that's not related to Member Map.

Share this post


Link to post
Share on other sites

I can see all members when I look at the map. One member can only see himself. I have logged into his account through the ACP and can see all members. However he has tried two different computers and two different browsers.

Any idea why he can't see other members??

Many thanks

Bill

I think we've worked it out. The member is accessing the map from his profile and only seeing his own marker.

Edited by Bill Edwards

Share this post


Link to post
Share on other sites

Great app, on first look there are no issues on my dev forum. Just a couple of suggestions from me. I will use the app as more or less live tracker of members, i.e. they will update the location often when they travel around the world. It would be great if there is a widget or something to show "members closest to you" or "who was in your region in the last 24h". This could create meet ups between members, which will strongly increase the social aspect of any community. 

Shouldn't be that hard to calculate mathematically knowing the coordinates, I can do the math part, but I am close to zero at developing. 

My second suggestion is if the location can be updated automatically, by either using GPS or IP address or something like this. It won't be involuntary, just instead of typing the location you can click a button to acquire it from gps. 

Anyway, regardless if you take this into consideration or not, thumbs up for the great work. Its been a while since I've been inspired about the potential of an app for my community. 

 

Share this post


Link to post
Share on other sites
9 hours ago, Martin A. said:

The same way you remove any other applications. ACP > Applications

It is deactivate an App only, but the files are still there. Is any way to remove an App totally?

Edited by ram108

Share this post


Link to post
Share on other sites
2 hours ago, ram108 said:

It is deactivate an App only, but the files are still there. Is any way to remove an App totally?

Delete /applications/membermap/.

5 hours ago, jair101 said:

Great app, on first look there are no issues on my dev forum. Just a couple of suggestions from me. I will use the app as more or less live tracker of members, i.e. they will update the location often when they travel around the world. It would be great if there is a widget or something to show "members closest to you" or "who was in your region in the last 24h". This could create meet ups between members, which will strongly increase the social aspect of any community. 

Shouldn't be that hard to calculate mathematically knowing the coordinates, I can do the math part, but I am close to zero at developing. 

This should be doable. 

5 hours ago, jair101 said:

My second suggestion is if the location can be updated automatically, by either using GPS or IP address or something like this. It won't be involuntary, just instead of typing the location you can click a button to acquire it from gps. 

Anyway, regardless if you take this into consideration or not, thumbs up for the great work. Its been a while since I've been inspired about the potential of an app for my community. 

You should see an option to use geolocation when adding/updating your marker, unless your using Chrome and not on a secure connection.

Share this post


Link to post
Share on other sites

I'm getting the following EX0 error on occasion when selecting Online Users. 

UnderflowException: lang_not_exists__membermap_group_2 (0)
#0 /home/findagra/public_html/system/Session/Front.php(452): IPS\_Lang->get('membermap_group...')
#1 /home/findagra/public_html/applications/core/modules/front/online/online.php(90): IPS\Session\_Front::getLocation(Array)
#2 [internal function]: IPS\core\modules\front\online\_online->IPS\core\modules\front\online\{closure}('loc_membermap_v...', Array)
#3 /home/findagra/public_html/system/Helpers/Table/Db.php(390): call_user_func(Object(Closure), 'loc_membermap_v...', Array)
#4 /home/findagra/public_html/system/Helpers/Table/Table.php(448): IPS\Helpers\Table\_Db->getRows(Array)
#5 /home/findagra/public_html/applications/core/modules/front/online/online.php(155): IPS\Helpers\Table\_Table->__toString()
#6 /home/findagra/public_html/system/Dispatcher/Controller.php(96): IPS\core\modules\front\online\_online->manage()
#7 /home/findagra/public_html/system/Dispatcher/Dispatcher.php(129): IPS\Dispatcher\_Controller->execute()
#8 /home/findagra/public_html/index.php(13): IPS\_Dispatcher->run()
#9 {main}

Share this post


Link to post
Share on other sites
5 minutes ago, Peter Drinkwater said:

I'm getting the following EX0 error on occasion when selecting Online Users. 

UnderflowException: lang_not_exists__membermap_group_2 (0)
#0 /home/findagra/public_html/system/Session/Front.php(452): IPS\_Lang->get('membermap_group...')
#1 /home/findagra/public_html/applications/core/modules/front/online/online.php(90): IPS\Session\_Front::getLocation(Array)
#2 [internal function]: IPS\core\modules\front\online\_online->IPS\core\modules\front\online\{closure}('loc_membermap_v...', Array)
#3 /home/findagra/public_html/system/Helpers/Table/Db.php(390): call_user_func(Object(Closure), 'loc_membermap_v...', Array)
#4 /home/findagra/public_html/system/Helpers/Table/Table.php(448): IPS\Helpers\Table\_Db->getRows(Array)
#5 /home/findagra/public_html/applications/core/modules/front/online/online.php(155): IPS\Helpers\Table\_Table->__toString()
#6 /home/findagra/public_html/system/Dispatcher/Controller.php(96): IPS\core\modules\front\online\_online->manage()
#7 /home/findagra/public_html/system/Dispatcher/Dispatcher.php(129): IPS\Dispatcher\_Controller->execute()
#8 /home/findagra/public_html/index.php(13): IPS\_Dispatcher->run()
#9 {main}

Confirmed, and fixed (in the next release). Will happen whenever one of your members are browsing the marker groups.

Share this post


Link to post
Share on other sites

I must be forgetting/omitting a permission setting somewhere or perhaps I'm missing how it it meant to work. I would like guests to see one set of custom markers (Show Venues) but not the members' markers.  This seems to work as expected for 'browsing' the marker tables but not on the map itself.

  • Application Settings
    Member Map → guests (checked)
    Marker Groups → guests (checked)
  • Marker Groups
    Members → guests (See Group, View Markers, Add Markers = unchecked)
    Show Venues → guests (See Group = checked, View Markers, Add Markers = checked)
  • Group Permissions → guests → Member Map (See Group, View Markers, Add Markers = unchecked)

Browsing groups works as expected. However the map itself still displays both members and custom markers with popups including name of member. Clicking the profile link on a member marker brings up the appropriate 'The page you are trying to access is not available to guests, but may be available if you sign in' message. 

I've reset the server cache via the map admin menu as well as flushing the site cache using the System Support tool. 

Pointers to what I'm overlooking appreciated. 

Edited by bradl
double-checked group permissions as well

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...