Jump to content
We are closed Thursday 23rd November and Friday 24th November. Support is still available via your client center but response times may be delayed.
Invision Community

Recommended Posts

I confess I'm not able to get any delete menu (or any menu for that matter) when interacting with the info window on a marker.  I just click the marker and get a name and description, with an X option to close the window.  Never mind...found it in Member Groups menu, which answered all my other questions :)

 

Edited by liquidfractal

Share this post


Link to post
Share on other sites

I am getting reports from my users that though the map shows up, the markers do not

Quote

Opening with Chrome Version 60.0.3112.113 (Official Build) (64-bit) running on Win 7:  map opens zoomed in to show Greenland and Norway, no markers, "Showing 0 markers" appears below the map.

IE 11, map opens showing "the whole world", lots of markers, zoom in and markers break into smaller groups.

this is at https://www.bmw2002faq.com/membermap/

I do not see issues in my browsers, so i cannot reproduce. 

Thanks,

Steve K.

Share this post


Link to post
Share on other sites
3 minutes ago, misfit76 said:

I am getting reports from my users that though the map shows up, the markers do not

this is at https://www.bmw2002faq.com/membermap/

I do not see issues in my browsers, so i cannot reproduce. 

Thanks,

Steve K.

Those issues are the worst, those you can't reproduce. Can you ask the user if there are any errors in the console? That's pretty much the only way I can fix this.

Share this post


Link to post
Share on other sites

Here is something:

Uncaught DOMException: Failed to execute 'setItem' on 'Storage': Setting the value of 'membermap.ips4_.markers_0' exceeded the quota.
    at Object.success (https://d2um9aptpsgwwp.cloudfront.net/javascript_membermap/front_front_main.js.2eeb7ddf0ddb3efe1b407383a33cfbda.js:85:15)
    at i (https://d2um9aptpsgwwp.cloudfront.net/javascript_global/root_library.js.4a5c9112397a4b568dc49e0977b9a825.js:2:27151)
    at Object.fireWith [as resolveWith] (https://d2um9aptpsgwwp.cloudfront.net/javascript_global/root_library.js.4a5c9112397a4b568dc49e0977b9a825.js:2:27914)
    at z (https://d2um9aptpsgwwp.cloudfront.net/javascript_global/root_library.js.4a5c9112397a4b568dc49e0977b9a825.js:2:76134)
    at XMLHttpRequest.<anonymous> (https://d2um9aptpsgwwp.cloudfront.net/javascript_global/root_library.js.4a5c9112397a4b568dc49e0977b9a825.js:2:79694)

 

Share this post


Link to post
Share on other sites
13 hours ago, Martin A. said:

Are you using @Adriano Faria's Club Enhancement? I think that may conflict with this.

same problem here : when using "Club Enhancements", the member map tab does not appear. (If the plugin is disabled, the member map tab appears).

Share this post


Link to post
Share on other sites
4 hours ago, marklcfc said:

I ran the support tool to clear cache and it said there was a database error. This was it.. do I click run automatically? This shouldn't have occured though?

 

I had the same after the update to 4.2.3.

Share this post


Link to post
Share on other sites
On 1.9.2017 at 3:14 PM, marklcfc said:

I ran the support tool to clear cache and it said there was a database error. This was it.. do I click run automatically? This shouldn't have occured though?

59a95d4d8b75d_supporttool.thumb.png.d3114cd6a293df1f0810322bd462289c.png

You can safely fix that automatically, or even ignore it. The difference it detected is just a "comment" on the "comment_id" column. The next release takes care of this.

On 1.9.2017 at 7:23 AM, Zorro_X said:

Hello again, 

May I ask you which key shall I use to translate the "Member Map" tab string ?

Thank you for the great job, it completely fulfills the goal of finding members of a club !

That would be 'frontnavigation_membermap' :) 

On 1.9.2017 at 0:45 AM, misfit76 said:

Here is something:

Uncaught DOMException: Failed to execute 'setItem' on 'Storage': Setting the value of 'membermap.ips4_.markers_0' exceeded the quota.
    at Object.success (https://d2um9aptpsgwwp.cloudfront.net/javascript_membermap/front_front_main.js.2eeb7ddf0ddb3efe1b407383a33cfbda.js:85:15)
    at i (https://d2um9aptpsgwwp.cloudfront.net/javascript_global/root_library.js.4a5c9112397a4b568dc49e0977b9a825.js:2:27151)
    at Object.fireWith [as resolveWith] (https://d2um9aptpsgwwp.cloudfront.net/javascript_global/root_library.js.4a5c9112397a4b568dc49e0977b9a825.js:2:27914)
    at z (https://d2um9aptpsgwwp.cloudfront.net/javascript_global/root_library.js.4a5c9112397a4b568dc49e0977b9a825.js:2:76134)
    at XMLHttpRequest.<anonymous> (https://d2um9aptpsgwwp.cloudfront.net/javascript_global/root_library.js.4a5c9112397a4b568dc49e0977b9a825.js:2:79694)

 

Can you ask the user to type this on the console? 

localStorage.clear();

That will clear the localStorage for your website. It doesn't store anything vital for your site, nor will it log him/her out. Typically what you'll find there is saved editor content and the notification count.
 

On 1.9.2017 at 6:45 PM, Josiah Wallingford said:

The widget/side bar is not seperating users by group. It does on the map itself but my members who are in "Staff" or any other group are still showing under "Other Members".

How does the sidebar determine who falls under "Staff"?

 

Screenshot at Sep 01 10-45-04.png

Those who show up on your staff page should also show as staff members in the sidebar. 

I'll look into grouping that list by member group as well.

Share this post


Link to post
Share on other sites
5 minutes ago, Martin A. said:

You can safely fix that automatically, or even ignore it. The difference it detected is just a "comment" on the "comment_id" column. The next release takes care of this.

Am I ok to leave it then or would you suggest fixing it

Share this post


Link to post
Share on other sites

There is no option to disable the side bar?

Some suggestions:

Add star rating here. Comments count still shows when disabled.

br.jpg.89685132c1ea806bd4281bd60681884e.jpg

ma.jpg.053f346a817639ee0381274cbcea374c.jpg

Option to hide the local time,It's not accurate.

Share this post


Link to post
Share on other sites

I'm running the latest version of IPS and the Member Map. Having just enabled Clubs, I created a test club to check out the features. All good. However, when I came to delete the test club, the deletion process seemed to hang for a long time. Later, I discovered a warning in the ACP about the 'queue' task, which was shown to be locked from the time I deleted the club. There was also a process hanging, 'Delete Members', related to the Member Map.

To clear this issue I had to disable Member Map and then unlock the 'queue' task and allow it to run. The 'Delete Members' process disappeared.

When I came to re-enable the Member Map, all my member markers were gone. Hundreds of them.

I'm concerned that his is a bug of some sort, related to clubs integration. I'm also very keen to get my markers back, if that is possible?

Share this post


Link to post
Share on other sites
24 minutes ago, JohnDar said:

I'm running the latest version of IPS and the Member Map. Having just enabled Clubs, I created a test club to check out the features. All good. However, when I came to delete the test club, the deletion process seemed to hang for a long time. Later, I discovered a warning in the ACP about the 'queue' task, which was shown to be locked from the time I deleted the club. There was also a process hanging, 'Delete Members', related to the Member Map.

To clear this issue I had to disable Member Map and then unlock the 'queue' task and allow it to run. The 'Delete Members' process disappeared.

When I came to re-enable the Member Map, all my member markers were gone. Hundreds of them.

I'm concerned that his is a bug of some sort, related to clubs integration. I'm also very keen to get my markers back, if that is possible?

Oh my, that is not good. That is not good at all! Expect a new version in a couple of minutes.

Unless you have a recent DB backup, getting your markers back is unlikely. Unless they're just "soft deleted", in that case your should still see then if you browse the markers.

Share this post


Link to post
Share on other sites

I'm glad if this has identified an issue for you, before anyone else goes down the same road.

I suspect they are hard deleted, but I do have a recent DB backup.

Ideally, I'd like to just import the members table, rather than restoring the entire database. Is that a possibility?

Share this post


Link to post
Share on other sites
1 minute ago, JohnDar said:

I'm glad if this has identified an issue for you, before anyone else goes down the same road.

I suspect they are hard deleted, but I do have a recent DB backup.

Ideally, I'd like to just import the members table, rather than restoring the entire database. Is that a possibility?

Not 100% sure if you can "cherry pick" a table from a complete backup. What I would do is import the backup as a new database, then export just the membermap_* tables, which you'll then import to your original database.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×