Jump to content

Installing in parallel with Parachat - getting error


cnmoore

Recommended Posts

We have Parachat installed, and I was told we can install IP Chat alongside of it, for comparison.

However, when I enable IP Chat I get error on index page: "Fatal error: Cannot redeclare class boardIndexWhosChatting in /home/mike/domains/spywareinfoforum.com/public_html/hooks/boardIndexWhosChatting_5e23529b380a024dd868696be11a5cd7.php on line 4"

I see that I have two "Who's chatting" hooks. What is best to do: Disable one? Which one?
For some reason I cannot attach screen shot.

Who's Chatting 

Show "Who's Chatting" block on board index 	Invision Power Services, Inc 	Today, 12:09 PM	 1.0.0 	 


Who's Chatting 

Shows who is in chat if installed and enabled 	Invision Power Services, Inc 	Dec 09 2009 05:49 PM	1.0.0

Link to comment
Share on other sites

Ah yes. The chat systems themselves can run in parallel, but it looks like there's a minor classname conflict if you try to have both hooks enabled at the same time.

If you disable one it should be fine. Disabling either one should be ok - they both check and update the same cache on the backend (so technically the "Who's chatting" block is going to show everyone in parachat AND ip.chat on the board index).

Link to comment
Share on other sites

I disabled the Parachat "Who's chatting" hook. Now I get a different error when I click Chat.
"[#CHAT-01] The chat room has not been properly setup by the administrator (the chat room account number has not been supplied)."

Configuration is a bit confusing. This evidently isn't right? (In my client area I was given a key but not an account number. See 2nd pic. I entered reference name ipschat.

Link to comment
Share on other sites

I ended up restoring from yesterday's public_html backup but that didn't fix the error. Even though IP Chat removed and Parachat restored, still get "[#1090] The chat room has not been properly setup by the administrator (the chat room account number has not been supplied)." when I try to access chat.

Now I'm screwed. No chat at all. Help!

Link to comment
Share on other sites

Managed to restore Parachat, although "Who's chatting" seems not to be working.

I would still like to try IP Chat, but it seems that there is a conflict with hook for "Who's Chatting", and with the nav bar Chat button (only one Chat button shows).

And also it is not clear to me how to configure the IP Chat. See pictures above. What goes in the Key field? The description says

Module Key


The name of the directory containing the module files. This should be alphanumeric only with no spaces or special characters.

That doesn't seem to really want a key? And yet the download says key must be used. Please clarify?
Link to comment
Share on other sites

Managed to restore Parachat.

I would still like to try IP Chat, but it seems that there is a conflict with hook for "Who's Chatting", and with the nav bar Chat button (only one Chat button shows).

And also it is not clear to me how to configure the IP Chat. See pictures above. What goes in the Key field? The description says

Module Key


The name of the directory containing the module files. This should be alphanumeric only with no spaces or special characters.

That doesn't seem to really want a key? And yet the download says key must be used. Please clarify?
Link to comment
Share on other sites

First of all, I'll say that IP.Chat and Parachat weren't tested concurrently. We didn't really forsee too many people trying to run both at the same time...that's the reason for the hook conflict.

You are editing the module it looks like (it's asking for a module key). What you need to do is

1) Install IP.Chat. It's an entirely separate application from Parachat/Addonchat (even though it actually has the same name in this release).

2) Go to My Apps -> IP.Chat

3) Enter your key here


You might want to submit a ticket if you're having trouble.

Link to comment
Share on other sites

Did I enter it in the right place last time?
http://community.invisionpower.com/index.php?app=core&module=attach&section=attach&attach_rel_module=post&attach_id=21366
It appeared to be asking for directory name, but I did enter key there.

Link to comment
Share on other sites

Did I enter it in the right place last time?
http://community.invisionpower.com/index.php?app=core&module=attach&section=attach&attach_rel_module=post&attach_id=21366
It appeared to be asking for directory name, but I did enter key there.

Link to comment
Share on other sites

Entered a ticket - got the usual great fast IPS support. They found that IP Chat just will not play nice with Parachat and said escalating and looking into it.

However I think we will just stay with Parachat which we like quite a bit.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...