Jump to content

[HQ] Forum Icons


InvisionHQ
 Share

Recommended Posts

My forum edits for the boardindexTemplate are

                                                <div class='f_icon'>          
                                                    <if test="hasUnread:|:$forum_data['_has_unread']">
                                                        <a id='forum_img_{$forum_data['id']}' href="{parse url="app=forums&module=forums&section=markasread&marktype=forum&forumid={$forum_data['id']}&returntoforumid={$this->request['f']}&i=1" base="public"}" data-tooltip="{$this->lang->words['bi_markread']}" class='forum_marker'><if test="$forum_data['icon'] != '' AND $forum_data['icon'] !='0'">{$forum_data['icon']}<else /><img src='{$this->settings['img_url']}/f_icon.png' /></if></a>                                                        
                                                    <else />
                                                        <if test="$forum_data['icon'] != '' AND $forum_data['icon'] !='0'">{$forum_data['icon']}<else /><img src='{$this->settings['img_url']}/f_icon_read.png' /></if>
                                                    </if>   
                                                </div>

The rest of the require edits on boardindexTemplate are fine to just replace.

For the forumindexTemplate edits, my changes are

										<div class='f_icon'>
											<if test="$forum_data['_has_unread']">
												<a id='forum_img_{$forum_data['id']}' href="{parse url="app=forums&module=forums&section=markasread&marktype=forum&forumid={$forum_data['id']}&returntoforumid={$this->request['f']}&i=1" base="public"}" data-tooltip="{$this->lang->words['bi_markread']}" class='forum_marker'><if test="$forum_data['icon'] != '' AND $forum_data['icon'] !='0'">{$forum_data['icon']}<else /><img src='{$this->settings['img_url']}/f_icon.png' /></if></a>
												<script type='text/javascript'>
													<if test="$this->settings['dp3_fi_mode'] == 'replace'">var unreadIcon = "{$forum_data['icon_read']}";</if>
													ipb.global.registerMarker( "forum_img_{$forum_data['id']}", "{$forum_data['img_new_post']}", markerURL + "&forumid={$forum_data['id']}" );
												</script>
											<else />
												<if test="$forum_data['icon'] != '' AND $forum_data['icon'] !='0'">{$forum_data['icon']}<else /><img src='{$this->settings['img_url']}/f_icon_read.png' /></if>
											</if>
										</div>

The rest of the edit are as instructed.

So the only real change to the edits is not to replace the <div class='f_icon'> with <td class='col_c_icon'> and </div> with </td>

Just paste the stuff in between, hope that helps.

Link to comment
Share on other sites

  • 2 weeks later...

Whenever I install any hook I now get the following error :

Fatal error: Class 'boardIndexRecentTopics' not found in /home/content/66/8708166/html/FxG_Forums/hooks/dp3_fi_boardsClassActionOverloader_60d891e05fd575a895521f15669f7b00.php on line 17

When I look at the Forum Icons FULL DETAILS I see that this file is associated with this addon... has anyone else had this error or have you seen this before ?? is there a fix for it ??

I am running IP Board 3.3.4 with FORUM ICONS 2.0.1

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...