Jump to content

(e32) Custom Sidebar Blocks


(e) Eric
 Share

Recommended Posts

  • 2 weeks later...

Yes it is still there if you leave the new setting set to No. However, if you are editing a PHP or RAW block, the fancy editor will not show, because it doesn't make sense to use on those types of blocks.


Thanks, (e)Eric.
I really don't need it, as I use to copy and paste the code from other blocks, but just in case....
I'm also using your custom codes. What to say? It's one of the best custom programs for IPB.
Link to comment
Share on other sites

Eric, If possible, I'd like to request a block be made, if you're still doing that, I tried to use your pinned topics block and modify it to make it happen but I just don’t have the necessary amount of knowledge of PHP apparently to make it work.

but what I'm trying to do is, a Recently Popular Topics block it displays the 5 topics (or a set number) with the most posts in the past month (or set amount of days / months).

I'd appreciate that if you've got the time.

Thanks.

Link to comment
Share on other sites

Does this work for people who use IPB itself to host their site? As I am very new to this, and can not seem to figure out how to install through the ACP with the directions. Any help or a link to how to install this via the ACP for users who do not have the folders and such to install would be great. Thank you and sorry if this is a dumb question.

Link to comment
Share on other sites


Eric, If possible, I'd like to request a block be made, if you're still doing that, I tried to use your pinned topics block and modify it to make it happen but I just don’t have the necessary amount of knowledge of PHP apparently to make it work.



but what I'm trying to do is, a Recently Popular Topics block it displays the 5 topics (or a set number) with the most posts in the past month (or set amount of days / months).



I'd appreciate that if you've got the time.



Thanks.




It should just be a slight modification to the existing Pinned Topics CSB, so I'll have a looksee and report back. :)


Does this work for people who use IPB itself to host their site? As I am very new to this, and can not seem to figure out how to install through the ACP with the directions. Any help or a link to how to install this via the ACP for users who do not have the folders and such to install would be great. Thank you and sorry if this is a dumb question.




I've never had an IPB hosted site, so I don't know. You definitely need to upload the files for it to work. I think they will install apps for you if you don't have access to your files, but I dunno. Anyone want to chime in?

I would post a ticket to ask if no one helps around here.
Link to comment
Share on other sites

It works but I think it should show the last post date and last poster picture instead of the date the topic was started and the topic starter picture.

Also it should include topics that were created at any time, but have been active within the past year or whatever amount of time. It should also omit closed topics.

Link to comment
Share on other sites

Hello Eric, I tried installing this app and I uploaded the files of the upload folder to their appropriate place, I saw and clicked the 'Install' link in the ACP and it seemed to install correctly. However, I couldn't find where to edit this app. It shows under 'Installed Applications', but none of the choices next to it allow me to edit it and add my content. I understand in the read me file states:

To use the application just scroll down the app dropdown in ACP to (e32) Custom Sidebar Blocks. Make sure in Manage Settings you enable the app, and make sure you add a block (or more) and enable it.



But I don't see any choices to actually edit this app and add custom content to it.

I went to the top of the ACP where it says 'Other Apps' and I saw the name '(e32) Custom Sidebar Blocks'. I clicked it and got this error message:



System Error



[#404] incorrect_furl




I don't see what else I'm suppose to upload or install. I see another folder with the download called 'extras', but your instructions don't say anything about that folder, so I left it alone since I'm not sure what those extras are for. Also, when we click the 'Install' link, which of the two choices from the drop down menu were we suppose to pick?

Any help in figuring this out would be appreciated.
Link to comment
Share on other sites


I don't see what else I'm suppose to upload or install. I see another folder with the download called 'extras', but your instructions don't say anything about that folder, so I left it alone since I'm not sure what those extras are for. Also, when we click the 'Install' link, which of the two choices from the drop down menu were we suppose to pick?



Any help in figuring this out would be appreciated.




Either choice should work for a fresh install. If it isn't finding the files when you visit the CSB page, I'm guessing the files were uploaded incorrectly. Double check your server and make sure all the CSB stuff is set appropriately. For instance, this is the main directory it needs: /admin/applications_addon/other/customSidebarBlocks/ And of course all the subfolders within that.

CSS_Helper, follow the README and go from there. :)
Link to comment
Share on other sites


Either choice should work for a fresh install. If it isn't finding the files when you visit the CSB page, I'm guessing the files were uploaded incorrectly. Double check your server and make sure all the CSB stuff is set appropriately. For instance, this is the main directory it needs: /admin/applications_addon/other/customSidebarBlocks/ And of course all the subfolders within that.



CSS_Helper, follow the README and go from there. :smile:




I double checked and I'm pretty sure I uploaded the files in their appropriate folders. This is how it looks in my ACP:

%7Boption%7D

That's the only place in the whole ACP where I see that app show up. I can't seem to find it anywhere else to add my content. If I click the 'Edit Application Details', nothing there to add my content. The drop-down menu next to it doesn't have any such settings either. Is there another area in the ACP where we edit and add our content?

By the way, what is the 'extras' folder for? Was I suppose to upload that as well?
Link to comment
Share on other sites


I double checked and I'm pretty sure I uploaded the files in their appropriate folders. This is how it looks in my ACP:



[img]

[/img]



That's the only place in the whole ACP where I see that app show up. I can't seem to find it anywhere else to add my content. If I click the 'Edit Application Details', nothing there to add my content. The drop-down menu next to it doesn't have any such settings either. Is there another area in the ACP where we edit and add our content?



By the way, what is the 'extras' folder for? Was I suppose to upload that as well?




Extras folder is just for the images and javascript and such for the README, it does not need to be uploaded, only the contents of the Upload folder need to be uploaded.

You do know you need to click the use the Other Apps dropdown in the top of ACP to navigate to other apps right? That is where you find the link to the CSB.

If that doesn't work still, try uninstalling and reinstalling.

The owner of this Program can you please Message me of More Instructions how to install this please




I don't offer private help via message, because if there really is a problem with the README then it needs to be publicly posted so I can fix it. So start from the first line of the instructions on how to install from the README and if you get stuck then post which part you got stuck on and we'll help. :)
Link to comment
Share on other sites

.



You do know you need to click the use the Other Apps dropdown in the top of ACP to navigate to other apps right? That is where you find the link to the CSB.



If that doesn't work still, try uninstalling and reinstalling.



Yes, that's what I mentioned in my first post. I hover over the tab at the top of the ACP that says "Other Apps" and one of the choices is (e32) Custom Sidebar Blocks. I then click that link and I get this error message:


System Error



[#404] incorrect_furl



So I'm not sure what could be the problem. But I'll give it another shot and uninstall it and install it one more time.
Link to comment
Share on other sites

I'm stuck on the first step

Upload the contents of the upload folder to your IPB 3.3 root directory. I don't get what are you trying to say

and Step 2 I logged in to my admin panel and went to System tab -> Manage Applications & Modules but I don't see Browse down to (e32) Custom Sidebar Blocks.

Link to comment
Share on other sites


Yes, that's what I mentioned in my first post. I hover over the tab at the top of the ACP that says "Other Apps" and one of the choices is (e32) Custom Sidebar Blocks. I then click that link and I get this error message:








Ok, I uninstalled it, used my FTP to delete the old files that I had uploaded. I then uploaded the files once again (very carefully). I went back to my ACP >>> Manage Applications and Modules >>> under 'Applications Not Installed' I clicked the 'Install' button (yes the Install Button did show up so there were no issues up to this point).

Remember in my first post where I asked:

Also, when we click the 'Install' link, which of the two choices from the drop down menu were we suppose to pick?



Well, the first time around I clicked the first choice and got nothing. This time around I clicked the second choice (since you mentioned that either choice should work well with a fresh install). I then clicked to install. Everything went well. I got no errors while the App was installing. It finished installing and then I hover over the tab at the top of the ACP that says "Other Apps" and once again one of the choices is (e32) Custom Sidebar Blocks. I then click that link and I get the same error message as I mentioned above. What can I be doing wrong? I uploaded the files carefully, otherwise I would not have gotten the link to 'Install' the App. The App installed without a problem. However, I still get that error message. Can it have anything to do with the fact that I'm using 3.3.4? What else am I suppose to edit once the App installs? Is there a separate hook I'm suppose to upload? Am I missing something?
Link to comment
Share on other sites


I'm stuck on the first step



Upload the contents of the upload folder to your IPB 3.3 root directory. I don't get what are you trying to say






Have you ever viewed your your forum's file system? If not, that would be the first step. You should download an ftp program and then connect to your server and start to browse around your files. Once you are done with that, go to the "root" of your server, which is the "top level" of your serer files. Possible its your actual root folder or in a "forums" or "public_html" or something like that subfolder. You'll know you are in your forum's root folder if you see: admin/, cache/, hooks/ conf_global.php, etc.

Once you have navigated to the root of your forum on the right (remote) side of your ftp program, navigate to the "upload" folder of the Custom Sidebar Blocks package you downloaded from here on the left side of the ftp program (be sure to unzip it first so you can browse the contents). Once you are inside the "upload" folder on the left side of your ftp program, highlight all those files and transfer them over to the right side, which is your forum root.

After uploading, you'll find the link to install CSB from your Manage Apps page.


Well, the first time around I clicked the first choice and got nothing. This time around I clicked the second choice (since you mentioned that either choice should work well with a fresh install). I then clicked to install. Everything went well. I got no errors while the App was installing. It finished installing and then [color=#282828][font=helvetica, arial, sans-serif] I hover over the tab at the top of the ACP that says "Other Apps" and once again one of the choices is [/font][/color](e32) Custom Sidebar Blocks[color=#282828][font=helvetica, arial, sans-serif]. I then click that link and I get the same error message as I mentioned above. What can I be doing wrong? I uploaded the files carefully, otherwise I would not have gotten the link to 'Install' the App. The App installed without a problem. However, I still get that error message. Can it have anything to do with the fact that I'm using 3.3.4? What else am I suppose to edit once the App installs? Is there a separate hook I'm suppose to upload? Am I missing something?[/font][/color]




Something funky must be going on, I searched for that "incorrect_furl" and found a bunch of topics with it, so you might try looking at others have had that problem and see what the fix was.

Another thing to try would be to try installing it on a fresh test board and if it works, try to see what might be different between the two boards.
Link to comment
Share on other sites


Something funky must be going on, I searched for that "incorrect_furl" and found a bunch of topics with it, so you might try looking at others have had that problem and see what the fix was.



Another thing to try would be to try installing it on a fresh test board and if it works, try to see what might be different between the two boards.




Well, so far I haven't read anyone using 3.3.4 reporting any issues similar to mine. We recently upgraded to 3.3.4, so the board is somewhat of a clean install. Unfortunately, the main owner of our site could not provide me with a Test Board, so I have no way of testing this App as you suggested. Shame too, I really wanted to use this App. We were using Beeman's Blank Sidebar Hook right before we upgraded to 3.3.4 from 3.1.4 and it has not given us any issues, but he has not replied to any support questions, which leads me to belive he's abandoned the support for his hook. And I'd rather not use it if I'm not certain it will work well with 3,3,4. Ever since I discovered this App of yours, I was dead set on using it for our future 3.3.4 upgrade and now I can't get it to work on our board. Oh well, thank you so much for your help though. Was much appreciated.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...