Jump to content

(e32) Custom Sidebar Blocks


(e) Eric
 Share

Recommended Posts

  • 2 weeks later...

Were you able to open the Read Me to read the instructions? After installing, you navigate to CSB menu via the Apps drop down. Then you would go to Manage Blocks and click Add Block. Then put whatever content you want. Then once done, you can add an arbitrary number more blocks.

Link to comment
Share on other sites

YW! :)

Someone on emoneyCodes.com found a bug which only occurs if you are installing 3.2 fresh without updating from a previous version (they moved a file). So if you get an error in ACP, then re-download the app and re-upload the files, and that should fix you.

Link to comment
Share on other sites


Someone on emoneyCodes.com found a bug which only occurs if you are installing 3.2 fresh without updating from a previous version (they moved a file). So if you get an error in ACP, then re-download the app and re-upload the files, and that should fix you.



Getting this error in ACP when going to Manage Settings :

Warning: require_once(C:/xampp/htdocs/ipb32/admin/applications/core/modules_admin/tools/settings.php) [function.require-once]: failed to open stream: No such file or directory in C:\xampp\htdocs\ipb32\admin\applications_addon\other\customSidebarBlocks\modules_admin\customSidebarBlocks\core.php on line 304

Fatal error: require_once() [function.require]: Failed opening required 'C:/xampp/htdocs/ipb32/admin/applications/core/modules_admin/tools/settings.php' (include_path='.;C:\xampp\php\pear\;C:/xampp/htdocs/ipb32/ips_kernel/') in C:\xampp\htdocs\ipb32\admin\applications_addon\other\customSidebarBlocks\modules_admin\customSidebarBlocks\core.php on line 304

Is this the error you are talking about here ?
Link to comment
Share on other sites


Yep, that's the one. It is looking for tools/settings.php which is where that file was in 3.0-3.1 However now it is in settings/settings.php. So re-download the package and re-upload the files (or just core.php). [img]

[/img]



Re-download & re-upload the files seem to solve the issue indeed.

Thanks ! %7Boption%7D
Link to comment
Share on other sites




Thanks ! [img]

[/img]




Hi ibEmoney



Thank you for making such a great mod. It's so nice of you to donate your time to make such a great mod ...it is really appreciated. [img]

[/img]




Thanks!!!!!!!!!!!




You're Welcome!!!!


How do you upgrade without loosing blocks etc?



thanks




The only way you would lose blocks is if you uninstalled first and then fresh installed. Uploading the new files and then upgrading via ACP (like in the Read Me instructions) should be fine. %7Boption%7D
Link to comment
Share on other sites


In ACP?



Is 3.2 your first version of IPB?



If so, I bet I know the issue. They moved the directory that contains the ACP icons. I'll fix tonight when I get home and release a patched version.



[color=orange]Hook Em![/color]





sweet


under custom block the cross.png image points towards: /admin/skin_cp/_newimages/icons/cross.png

The _newimages folders dosen't exist



btw, i just created a test block and it's showing. It seems to have the cross.png images under enabled.

How do I turn it on?
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...