June 25, 2009 in Feedback
The docs that ship with IPB v3.0 say this (from Documentation/InstallationGuide/install_guide.html):Requirements
The exact requirements of your, or a, server will depend on many factors, your estimated board traffic being one. While we can offer advice about what hardware would be best to use on your server, there is no one setup that works for all.
You must have a webserver that has PHP 5.1.0 (or better) and MySQL 4.1 or higher (MySQL 5.0 or higher preferred) installed. If you are unsure whether your server has these programs installed, please check with your web host now. If you are capable, you....
However, after trying to upgrade and after copying over all my files, I was getting errors with debug_backtrace() having the wrong number of parameters, and other errors. When I found and ran check_requirements.php, it says you need PHP 5.2.0.
Currently the default yum setup on Centos only has PHP v5.1.6, so this is a deal-breaker for us (http://www.unknownworlds.com/ns2/forums). I imagine you'll want to fix this in your docs, and also make it easier to run the check_requirements script for upgrade installs.
This should be posted as a bug in the bug tracker, refer to the note at the top of the page.
Yes, please post the errors you faced in the bug tracker. :) I tested 5.1.0 yesterday and found one bug, which I fixed, but I didn't run a new installation (just tested a setup I already had).
Also got the same information on here -> http://www.invisionpower.com/products/requirements.php?app=board
Bar the fact that there's a minimum and recommended requirements.
Any bugs preventing installation or usage on PHP 5.1 should be reported to the bug tracker.
This topic is now archived and is closed to further replies.
Started 19 minutes ago
Started February 18
Started 2 hours ago