Jump to content

PHP version incorrect


Recommended Posts

Hey guys,

The docs that ship with IPB v3.0 say this (from Documentation/InstallationGuide/install_guide.html):

The exact requirements of your, or a, server will depend on many factors, your estimated board traffic being one. While we can offer advice about what hardware would be best to use on your server, there is no one setup that works for all.

You must have a webserver that has PHP 5.1.0 (or better) and MySQL 4.1 or higher (MySQL 5.0 or higher preferred) installed. If you are unsure whether your server has these programs installed, please check with your web host now. If you are capable, you....

However, after trying to upgrade and after copying over all my files, I was getting errors with debug_backtrace() having the wrong number of parameters, and other errors. When I found and ran check_requirements.php, it says you need PHP 5.2.0.

Currently the default yum setup on Centos only has PHP v5.1.6, so this is a deal-breaker for us (http://www.unknownworlds.com/ns2/forums). I imagine you'll want to fix this in your docs, and also make it easier to run the check_requirements script for upgrade installs.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...