Jump to content

Marketplace

Fake Content Generator 0.2.1

   (4 reviews)

7 Screenshots

Important Note: This application is intended for use by developers only. Please do not install this application on a production server.

Faker provides developers and theme designers with a means of quickly and easily generating fake (boilerplate) content on their development installations.

This application is currently in pre-release status. It is currently limited generating member accounts and forum topics at the moment, but I plan on offering a means of easily extending the application so that it can be used to generate boilerplate content on custom third party applications in the future.

Git repository:
https://dev.taiga.sh/makoto/IPS-Faker


What's New in Version 0.2.1   See changelog

Released

Fixed

  • Updates the password hashing methods in the Member generator to be compatible with IPS 4.3/4.4
  • Resolves issues with the Forums generator throwing an error
  • Removes references to the deprecated NumberRange Form helper
  • Call functions from root namespaces (IPS 4.4 Standards Compliance)

This is a developer resource, so no support is guaranteed. Please report bugs to the Gitlab issues page if you can.


User Feedback

You may only provide a review once you have downloaded the file.


AndyF

· Edited by AndyF

   2 of 2 members found this review helpful 2 / 2 members

At last a new version of this very useful tool. 🙂

It worked well enough for me in creation of topics with and without posts and member creation too. I tested it on suite version 4.3.6.

On another positive note it is pleasing to see there is the possibility of it being extended to cover other area's of the suite too.

On a negative note the 'topic posts' does not appear to function at all. I have not looked into this in detail however despite trying various URL types (just the ID and/or the full URL) I suspect it may not work properly if the suite is not in the root directory, as in in a sub-dir.

Summary: I'm quite happy overall though., +1

Link to comment
itz_corey650

   1 of 2 members found this review helpful 1 / 2 members

Gives config errors on 4.2 and the only thing that works is purge content but if we cant create any in the first place then it don't make sense lel

Response from the author:

This application has been updated with support for IPS 4.3 and 4.4 as of February 15th, 2019.

Support for version 4.2 is no longer provided.

Link to comment
alexch

· Edited by alexch

   0 of 1 member found this review helpful 0 / 1 member

Configuration errors on IPS 4.2. It doesnt create any content.

 

Link to comment
×
×
  • Create New...

Important Information

We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. We also share information about your use of our site with our trusted social media, advertising and analytics partners. See more about cookies and our Privacy Policy